Messaging and Live Chat Outage

Incident Report for TeamSupport System

Resolved

All Messaging and Live Chat services impacted by the recent Google Cloud outage have been fully restored and are now operating normally
Posted Jun 12, 2025 - 18:47 CDT

Update

Google Cloud has confirmed improvements across regions, and full resolution is expected soon. We’ll share updates as we learn more.
Posted Jun 12, 2025 - 16:30 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 15:31 CDT

Update

Google has applied mitigations and most services are recovering. Some customers may still experience intermittent issues as full recovery is still in progress. We’re continuing to monitor and will share updates as available.
Posted Jun 12, 2025 - 15:31 CDT

Update

Google has identified the root cause and applied mitigations. Most services are recovering, though some users may still see intermittent impact depending on the Google Cloud products in use. We’re monitoring closely and will share further updates as available.
Posted Jun 12, 2025 - 14:51 CDT

Monitoring

Messaging and Live Chat remain impacted due to a broader Google Cloud outage. Google has confirmed partial recovery in some regions, but there is no ETA for full resolution. We are actively monitoring and will share updates as they become available.
Posted Jun 12, 2025 - 14:22 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 14:20 CDT

Identified

We're currently experiencing a disruption to Messaging & Live Chat due to a broader outage with Google Cloud services. Our team is actively monitoring the situation and will provide updates as they become available.
Posted Jun 12, 2025 - 13:27 CDT
This incident affected: Messaging & Live Chat Application - Web (North America, European Union).